Skip to content

Installation

The TIM Python client is uploaded to the Python Package Index (PyPI), a repository of software for Python. This also means that it can easily be installed using pip, more information on installing packages can be found in their documentation.

Requirements

In order to use the TIM Python client, the following requirements need to be fulfilled:

  • Software requirements
  • Python 3.6 or higher
  • pip
  • Network requirements
  • a permanent internet connection
  • License requirements
  • a valid TIM license and corresponding user credentials (license key, email and password)

Installing the TIM Python client will also install the following dependencies:

Installation

Provided you have pip available from the command line, it suffices to run pip install tim-client to install the TIM Python client as a system-wide package (recommended).